US backbone network interruptions
Updated
Mar 13 at 03:41am CDT
We have not received official "all clear" from our upstream provider, but service stability has returned as of 30 minutes ago. We are continuing to monitor and will leave the incident open until we receive confirmation of resolution.
Affected services
Created
Mar 13 at 02:49am CDT
We are currently experiencing an ongoing incident with an upstream service provider. The problem is causing increased latency and intermittent timeouts in some environments. We are monitoring the situation and will post updates as they become available.
Affected services